New posts

shoulda bought a mac?

March 12, 2019, 7:55 p.m.
Posts: 8
Joined: May 29, 2007

If you're on the Shore try Mac Place on Lonsdale at 2nd. They're good.

March 12, 2019, 9:11 p.m.
Posts: 103
Joined: June 17, 2016

Posted by: Endur-Bro

Thread bump

Have a late 2011 MBP.

At startup the MBP shows the apple logo and load bar. The screen is a mix of white horizontal bars across the screen. Load bar won’t progress to login screen. Goes grey/white afterwards.

Is the GPU toast?

Yes, GPU toast, pretty amazing yours lasted this long, it's a known problem with that model. Mine started failing in 2015. Had to buy a new one as I rely on it for work.

However, there is a hack to disable the GPU and run on the secondary graphics chip full time. I did this on my old 2011 and my wife is still using it to this day. The only thing it can't do anymore is 3D stuff, but everything else works.

Don't remember exactly what I did but found this link in my bookmarks, I think that was one of the pages describing the hack/fix:

https://forums.macrumors.com/threads/force-2011-macbook-pro-8-2-with-failed-amd-gpu-to-always-use-intel-integrated-gpu-efi-variable-fix.2037591/

It's pretty hardcore geek level, so only attempt if you know what you are doing. On the other hand, you got nothing to lose ;-)


 Last edited by: niels@nsmb.com on March 12, 2019, 9:15 p.m., edited 1 time in total.
March 12, 2019, 9:55 p.m.
Posts: 701
Joined: March 18, 2017

Haha. Eff me. Exciting time to be myself.

March 13, 2019, 8:31 a.m.
Posts: 103
Joined: June 17, 2016

May still be worth checking in with an independent repair shop, it could be just weak soldering.

March 13, 2019, 8:35 p.m.
Posts: 701
Joined: March 18, 2017

^Weak solder is my first choice. Then I’ll go from there. 

Thanks

Forum jump: