New posts

Reverb- Stuck

Nov. 17, 2015, 1:41 p.m.
Posts: 8242
Joined: Dec. 23, 2003

i didn't even know it was there. after a bleed my post wasn't playing nice. did a bunch go googling..voila!!

Nov. 17, 2015, 2:56 p.m.
Posts: 2121
Joined: Nov. 6, 2005

^^ i don't buy anything nowadays that doesn't have a fix-it button

Yeah… every bike component should come with one of these…

Nov. 17, 2015, 6:02 p.m.
Posts: 8242
Joined: Dec. 23, 2003

i know people who should mount one of those right in the middle of their face…..

March 16, 2016, 2:20 p.m.
Posts: 1781
Joined: Feb. 26, 2015

So sent my dropper off in early Feb to be serviced under warranty. It's acting up again…
Its getting stuck down or won't go down, depends on its mood. Looks like yet another bleed.

Kinda over this thing.

People always ask me what's the phenomenon
Yo what's up? Yo what's goin' on- Adam Yauch

March 16, 2016, 2:44 p.m.
Posts: 2408
Joined: Sept. 5, 2012

So sent my dropper off in early Feb to be serviced under warranty. It's acting up again…
Its getting stuck down or won't go down, depends on its mood. Looks like yet another bleed.

Kinda over this thing.

who serviced it ??

#northsidetrailbuilders

March 16, 2016, 2:51 p.m.
Posts: 2116
Joined: Aug. 4, 2009

I don't get reverbs, wtf is the need for a hydraulic line? On brakes it makes sense but come on, a seatpost?

March 16, 2016, 3:01 p.m.
Posts: 1781
Joined: Feb. 26, 2015

who serviced it ??

Sent off to Norco for warranty

People always ask me what's the phenomenon
Yo what's up? Yo what's goin' on- Adam Yauch

March 16, 2016, 3:12 p.m.
Posts: 2408
Joined: Sept. 5, 2012

Sent off to Norco for warranty

aaah should have taken it too Squamish to the experts at Fluid Function

#northsidetrailbuilders

March 17, 2016, 9:37 a.m.
Posts: 1
Joined: Jan. 8, 2015

I've had the same issue with two reverb dropper posts. On cold days they would stop working mid ride and then when I check them in the garage the next morning, they would magically be working again. I had both posts bled multiple times by different mechanics and nothing helped. One of the posts was about a year old the other one was brand new. According to mechanics I talked to it's just an issue with reverb dropper posts - they stop functioning when it's cold outside.

I heard there is a cold weather mod you can make so this issue doesn't happen. Does anybody have any details on this?

March 17, 2016, 9:59 a.m.
Posts: 10077
Joined: Nov. 19, 2002

I heard there is a cold weather mod you can make so this issue doesn't happen. Does anybody have any details on this?

Borealis fat bikes (out of Alaska) has cold weather kits available for Bluto forks, there is a good chance they have a similar kit available for the Reverb although I don't see it listed on their page. (Their in house component brand is Turnagain Cycles.)

http://www.fatbike.com/shop25/catalog-listadv.cfm?cat_display=cp[HTML_REMOVED]storeid=5

March 17, 2016, 1:53 p.m.
Posts: 1781
Joined: Feb. 26, 2015

I've had the same issue with two reverb dropper posts. On cold days they would stop working mid ride and then when I check them in the garage the next morning, they would magically be working again. I had both posts bled multiple times by different mechanics and nothing helped. One of the posts was about a year old the other one was brand new. According to mechanics I talked to it's just an issue with reverb dropper posts - they stop functioning when it's cold outside.

I heard there is a cold weather mod you can make so this issue doesn't happen. Does anybody have any details on this?

I had one that was 4 years old that never had to be serviced once. Too bad it was the wrong diameter for the new bike and I sold it. I guess the reverb being mass produced has lowered the quality. Also have heard that the new generation has a better set of seals. The year old ones like I have are a bad batch. Have to say I am stoked bleeding the post every two weeks.

Thx for the help guys.

People always ask me what's the phenomenon
Yo what's up? Yo what's goin' on- Adam Yauch

Forum jump: